Introduction

SEF File Format Support

The Encryption plug-in is an archive manager plug-in for ACD digital-imaging management products. With this plug-in you can create and open Strong Encryption Format (.sef) archives.

Archive single or multiple files under one password with full compression capabilities. The Encryption plug-in even provides you with the option of deleting your original files after the archive has been created. Securely store items such as sensitive documents, business plans and confidential drawings.

The Strong Encryption Format

SEF files are cryptographic archives used to store files in a secure manner. These files make use of the Twofish encryption algorithm with a 256-bit key.

Because of the highly optimized compression and encryption routines used with the Strong Encryption Format, a seamless integration occurs with almost any kind of application. For example, suppose you have several TIFF images of faxes that you wish to remain private. Simply add them to a .sef archive and delete the originals. Any time you wish to work with your faxes, all you have to do is select the file and enter your password.

Opening an SEF File Using ACDSee

The Encryption plug-in caches the last used password until a library function is called by ACDSee. When a SEF archive is created by overwriting another one, the file may open without having to enter a password.


AM_Encryption Settings

Adjusting Settings

It is possible to control the amount of compression used when creating your encrypted archive. The compression affects the .sef archive and not the files contained within.

To adjust the compression level, do one of the following:

  • Move the slider to the left for less compression.

  • Move the slider to the right for more compression.

The length of time it takes to create an archive increases as the compression level is raised. If you would like to save this setting as the default for future use, select Save settings.

Compression

The Encryption plug-in uses ZLIB lossless data-compression to compress files for archival purposes. The percentage of compression can vary depending on the file type, the data the file contains, and the level of compression you define in the settings.

For example:

  • When compressing JPEG files, there will be almost no compression, no matter what you set the level to. This is because JPEG files are already compressed.

  • Compressing very small files provides little noticeable difference.

  • There is a difference when compressing ten 200KB Word documents using Level 9, and then comparing that to a compression of the same documents using Level 3 (providing the Word documents don't contain a large series of repetition like the word 'test' over and over).


Using Appropriate Passwords

Using passwords of less than 12 characters makes it feasible for others to break into your SEF files, when given enough time.

The mathematics behind this premise are simple. If a password is 12 characters long and consists of uppercase and lowercase letters, as well as numbers and punctuation marks, the number of possible characters that can be used for each letter of the password is 256. This means that there are 256^12 or 7.9 x 10^28 different password combinations. No amount of computing power currently available would be able to run through this many combinations in a reasonable time (it would take 1.0 x 10^10 years to break this password).

E.g., TH1Sis@test* = 12 characters


.topic 42
Confirm your password.

.topic 41
Enter your password.

.topic 22
Saves your settings as default.

.topic 21
Adjust the slider to control the amount of compression used. For more information regarding compression, please see the help file.